home *** CD-ROM | disk | FTP | other *** search
/ Aminet 45 / Aminet 45 (2001)(GTI - Schatztruhe)[!][Oct 2001].iso / Aminet / game / 2play / freeciv_hires.lha / Freeciv / data / hires / cities.spec < prev    next >
Text File  |  2001-08-17  |  3KB  |  150 lines

  1. ;
  2. ; The names for city tiles are not free and must follow the following rules.
  3. ; The names consists of style name, _ , size. The style name is as specified
  4. ; in cities.ruleset file. The size indicates which size city must
  5. ; have to be drawn with a tile. E.g. european_4 means that the tile is to be
  6. ; used for cities of size 4+ in european style. Obviously the first tile
  7. ; must be style_name_0. The sizes must be in ascending order.
  8. ; There must also be a style_name_wall tile used to draw the wall and
  9. ; an occupied tile to indicate a miltary units in a city.
  10. ; The maximum size supported now is 31, but there can only be MAX_CITY_TILES
  11. ; normal tiles. The constant is defined in common/city.h and set to 8 now.
  12. ;
  13.  
  14. [spec]
  15.  
  16. ; Format and options of this spec file:
  17. options = "+spec2"
  18.  
  19. [info]
  20.  
  21. artists = "
  22.     Tim F. Smith <yoohootim@hotmail.com>
  23. "
  24.  
  25. [file]
  26. gfx = "hires/cities"
  27.  
  28. [grid_main]
  29.  
  30. x_top_left = 1
  31. y_top_left = 39
  32. dx = 64
  33. dy = 48
  34. is_pixel_border = 1
  35.  
  36. tiles = { "row", "column", "tag"
  37.  
  38. ; default tiles
  39.  
  40.  1,  2, "cd.city"
  41. ; 1,  3, "cd.city_wall"
  42. ; 1,  4, "cd.occupied"
  43.  
  44. ; used by all city styles
  45.  
  46. ; 0,  0, "city.disorder"
  47.  
  48. ;
  49. ; city tiles
  50. ;
  51.  
  52.  1,  0, "city.classical_0"
  53.  1,  1, "city.classical_5"
  54.  1,  2, "city.classical_10"
  55.  1,  3, "city.classical_15"
  56.  
  57.  3,  0, "city.european_0"
  58.  3,  1, "city.european_5"
  59.  3,  2, "city.european_10"
  60.  3,  3, "city.european_15"
  61.  
  62.  4,  0, "city.industrial_0"
  63.  4,  1, "city.industrial_5"
  64.  4,  2, "city.industrial_10"
  65.  4,  3, "city.industrial_15"
  66.  
  67.  5,  0, "city.modern_0"
  68.  5,  1, "city.modern_5"
  69.  5,  2, "city.modern_10"
  70.  5,  2, "city.modern_15"
  71.  
  72. ;we just use modern here too
  73.  5,  0, "city.postmodern_0"
  74.  5,  1, "city.postmodern_5"
  75.  5,  2, "city.postmodern_10"
  76.  5,  3, "city.postmodern_15"
  77.  
  78. }
  79.  
  80. [grid_specials]
  81.  
  82. x_top_left = 143
  83. y_top_left = 423
  84. dx = 64
  85. dy = 48
  86. is_pixel_border = 1
  87.  
  88. tiles = { "row", "column", "tag"
  89.  
  90.  0, 0, "unit.fortified"
  91.  0, 1, "tx.fortress"
  92.  0, 2, "tx.airbase"
  93.  0, 3, "tx.airbase_full"
  94. }
  95.  
  96. [grid_flags]
  97.  
  98. x_top_left = 1
  99. y_top_left = 425
  100. dx = 14
  101. dy = 22
  102. is_pixel_border = 1
  103.  
  104. tiles = { "row", "column", "tag"
  105.  
  106.  0, 6, "city.european_occupied", "city.classical_occupied",
  107.        "city.industrial_occupied", "city.modern_occupied",
  108.        "city.postmodern_occupied"
  109. }
  110.  
  111. [grid_walls]
  112.  
  113. x_top_left = 334
  114. y_top_left = 39
  115. dx = 64
  116. dy = 48
  117. is_pixel_border = 1
  118.  
  119. tiles = { "row", "column", "tag"
  120.  
  121. ; city tiles
  122.  
  123.  1,  0, "city.classical_0_wall"
  124.  1,  1, "city.classical_5_wall"
  125.  1,  2, "city.classical_10_wall"
  126.  1,  3, "city.classical_15_wall"
  127.  
  128.  3,  0, "city.european_0_wall"
  129.  3,  1, "city.european_5_wall"
  130.  3,  2, "city.european_10_wall"
  131.  3,  3, "city.european_15_wall"
  132.  
  133.  4,  0, "city.industrial_0_wall"
  134.  4,  1, "city.industrial_5_wall"
  135.  4,  2, "city.industrial_10_wall"
  136.  4,  3, "city.industrial_15_wall"
  137.  
  138.  5,  0, "city.modern_0_wall"
  139.  5,  1, "city.modern_5_wall"
  140.  5,  2, "city.modern_10_wall"
  141.  5,  2, "city.modern_15_wall"
  142.  
  143. ;we just use modern here too
  144.  5,  0, "city.postmodern_0_wall"
  145.  5,  1, "city.postmodern_5_wall"
  146.  5,  2, "city.postmodern_10_wall"
  147.  5,  3, "city.postmodern_15_wall"
  148.  
  149. }
  150.